freebsd 6.* 无法安装 ZendOptimizer-3.2.6 解决方法

PHP5研究室 2007年04月18日 15:03 查看6797次 作者: esayr  【
文章分类:PHP5研究[新]

今晚升级本站所在的服务器到apache2.2.4和php5.2.1 .但最后发现没法装上ZendOptimizer-3.2.6

解压ZendOptimizer-3.2.6-freebsd6.0-i386.tar.gz后运行./install.sh安装,总是提示:

zend# ./install.sh
Please, wait ...

Zend Optimizer installation was NOT completed successfully.

File: ./dialog does not exist!

For further assistance, please contact Zend Support at
https://www.zend.com/support/
[To continue, press Enter]

 

而 ZendOptimizer-3.0.2-freebsd6.0-i386.tar.gz  倒是可以安装.却和php5.2.1不兼容. 最后搜索到官方.找到答案.共享给大家.

同时下载ZendOptimizer-3.2.6-freebsd6.0-i386.tar.gz 和 ZendOptimizer-3.0.2-freebsd6.0-i386.tar.gz 并解压缩.

补充:发现比较难找.我提供两个地址:

http://ftp.giga.net.tw/OS/FreeBSD/distfiles/ZendOptimizer-3.0.2-freebsd6.0-i386.tar.gz

(3.2.8发布了,可惜还是有问题)http://ftp.giga.net.tw/OS/FreeBSD/distfiles/ZendOptimizer-3.2.8-freebsd6.0-i386.tar.gz

复制

 ZendOptimizer-3.0.2-freebsd6.0-i386/zui_files/dialog

ZendOptimizer-3.2.6-freebsd6.0-i386/zui_files/

像这样:

phpv@root# cp ZendOptimizer-3.0.2-freebsd6.0-i386/zui_files/dialog ZendOptimizer-3.2.6-freebsd6.0-i386/zui_files/

这样,再运行./install.sh就可以像以前那样安装上了.

再查看phpinfo() 终于出来

with Zend Optimizer v3.2.6, Copyright (c) 1998-2007, by Zend Technologies

这只是个小问题.但也希望官方早日改进.

责任编辑:easy

给文章打分...

平均分:0.5(39 次)

-5 -4 -3 -2 -1 0 1 2 3 4 5
0

顶一下

发表我的见解...

  • 您的大名: 留空为匿名
  • 您的主页:
  • 您的邮箱: